Sie sind nicht angemeldet.

1

Dienstag, 18. März 2014, 17:11

Security Board

Für alle die es interessiert:
Das Security Board des ET9200 hängt über einen USB-Hub an einem USB Port der Hauptplatine.
Es ist mit einer 32Bit Cortex-M3 CPU bestückt, die ein internes SRAM hat, was vermutlich den Security-Schlüssel beherbergt.
Laut Spezifikation dieses STM42F103VD braucht dieser interne Speicher eine Erhaltungsspannung von mindestens 1.8V.
Da die Backup-Quelle, also die Batterie, über eine Schottky-Diode an dem STM hängt darf man hier mindestens 200-300mV sicherheithalber dazuzählen.
Laut Datenblatt braucht der Controller maximal 2uA bei 85°C, womit man die Lebensdauer etwa abschätzen kann.
Eine 2032er Lithium Zelle hat etwa 200mAh, was ca. 100000 Stunden bis zu einer Entladespannung von 2.0V bei 2uA ergeben würde.
Diese Kalkulation bezieht sich auf 20°C Umgebungstemperatur, d.h. je höher die Temp. desto kürzer die Lebensdauer.
Wer also sicher gehen will, dass das Security-Board noch "sicher" ist, sollte die Batteriespannung nicht unter 2,1V fallen lassen !
Es ist auch kein Problem das Security-Board einfach über die beiden kleinen weißen Stecker vom Hauptboard und dem Front-USB-Port zu trennen.
Natürlich sollte das nur gemacht werden, während die ET9200 ausgeschalten und völlig vom Netz getrennt ist.
Das dürfte einen Batteriewechsel wesentlich vereinfachen.
Während des Wechselns darf der STM natürlich niemals ohne Backup-Versorgung sein, d.h. eine externe Batterie die nicht über 3.6V liefern darf ist unumgänglich.
Für den Fall des Ausbaus, sollte man in jedem Fall auf ESD Schutz und einen geeigneten Lagerplatz für das Security-Modul achten, also kein Metalltisch oder sonstige Unterlagen, die einen Kurzschluß auf dem Modul verursachen können !!!
Den Xtrend ohne Security-Modul einzuschalten würde ich auch nicht unbedingt versuchen, da ich nicht weiß, ob er sich das irgendwo merkt, dass das Teil mal gefehlt hat.

Murphy-09 :)

2

Dienstag, 18. März 2014, 17:55

Wenn das Sec. Board an einem USB Anschluss hängt könnte man doch zur Unterstützung der Batterie einen Powerpack an einen USB Anschluss hängen ?

Oder sind die USB Anschlüsse von der Spannung her getrennt ?

GameDream

3

Dienstag, 18. März 2014, 19:30

Security Board

na ja, sobald die Versorgung auf dem Board vorhanden ist, wird das Teil aktiv werden und ich weiß nicht was checken.
Im Backup Fall ist der STM nur intern aktiv, d.h. nach außen relativ tot, um Energie zu sparen.
In diesem Fall ist es am einfachsten ihm eine neue Batterie unter zu jubeln.

Murphy-09

4

Dienstag, 18. März 2014, 19:48

Wenn ich das richtig gerechnet habe sind die 100000 Std umgerechnet ca. 11 Jahre und ein paar Monate also ich mache mir da keine Gedanken deswegen. Da geben vorher noch Elcos .. den geist auf. An meiner Vu+ duo sind nach 3,5 jahre auch schon Elcos kaputt gegangen also würde ich da nicht viel drauf geben. Meine Dreambox 5000 ca. 8 jahre weiss gar nicht mehr genau, hat jetzt auch erst den Geist aufgegeben.

MFG
Xtrend 8000, Gigablue Quad, Wavefrontier T 90 8 Lnbs

5

Dienstag, 18. März 2014, 20:21

...... 11 Jahre und ein paar Monate also ich mache mir da keine Gedanken deswegen. .....
Hmmm, verstehe ich nicht, daß man so blauäugig sein kann. 8| . Es mag sein, daß gerechnet die Batterie so lange halten kann bei dem niedrigen Stromverbrauch. Aber was ist mit der chemischen Zersetzung im inneren. Auch wenn es sich um bessere Alkalibatterien handelt können diese auslaufen, und das wartet bestimmt keine 11 Jahre auf sich. Einzig Lithiumbatterien, wären eine Alternative, allerdings sind die von jetzt auf gleich leer.
Ich würde lieber defekte Elko's in kauf nehmen als die blöde Ungewissheit, wann denn das Sec-Board sein Leben aushaucht.
Xtrend ET9500 / WD 3TB / OpenPLI 4 (02.13.2014)

6

Dienstag, 18. März 2014, 20:48


Aber was ist mit der chemischen Zersetzung im inneren. Auch wenn es sich um bessere Alkalibatterien handelt können diese auslaufen, und das wartet bestimmt keine 11 Jahre auf sich. Einzig Lithiumbatterien, wären eine Alternative, allerdings sind die von jetzt auf gleich leer.

Zu deiner Information ist die verbaute CR2032 eine Lithiumbatterie und keineswegs "gleich leer". Auslaufen können die auch nicht. Woher nimmst du nur diese Informationen, saugst du das aus deinen Fingern?

7

Donnerstag, 3. April 2014, 13:10

Den Xtrend ohne Security-Modul einzuschalten würde ich auch nicht unbedingt versuchen, da ich nicht weiß, ob er sich das irgendwo merkt, dass das Teil mal gefehlt hat.

Murphy-09 :)


Könnte schon sein.

Vielleicht hat ja im Forum hier irgendeiner eine defekte Box mit framebuffer fatal error rumliegen und startet die Kiste mal ohne das Sec. Board, dafür mit Putty am seriellen Port ^^
Dann könnte man zumindest die Logs vergleichen, LOG mit defektem Sec.B. = LOG ohne Sec.B.

Im Gewährleistungsfall wird ja scheinbar nur gegen Neuteile getauscht, da kein JTAG verbaut. Wahrscheinlich wird der Box nach Sec.Board Tausch ein zum neuen Sec.Board passender Bootloader verpasst. Zumindest denke ich das, da ansonsten die Dinger quer von einer zur anderen Box tauschbar wären...

Ich würde lieber defekte Elko's in kauf nehmen als die blöde Ungewissheit, wann denn das Sec-Board sein Leben aushaucht.


Ganz deiner Meinung...
2x ET 9200 - 1x ET 6000

XtrendIM

Administration+Technik+Support

Beiträge: 3 703

Wohnort: Europa

  • Nachricht senden

8

Donnerstag, 3. April 2014, 15:34

Wahrscheinlich wird der Box nach Sec.Board Tausch ein zum neuen Sec.Board passender Bootloader verpasst.


Das ist nicht korrekt.
Der Bootloader ist überall gleich! Und die Box würde auch bei Defekt am Sec.-Board überhaupt nicht booten .-)

9

Donnerstag, 3. April 2014, 16:41

Wahrscheinlich wird der Box nach Sec.Board Tausch ein zum neuen Sec.Board passender Bootloader verpasst.


Das ist nicht korrekt.
Der Bootloader ist überall gleich! Und die Box würde auch bei Defekt am Sec.-Board überhaupt nicht booten .-)



Das ist nur bedingt richtig. Der Bootloader ist zwar überall gleich, aber der Rest von NOR-Flash-Inhalt nicht.
Der Bootloader benutzt ja nur maximal 512KB der 4MB NOR-Flash Kapazität.
Im Bereich ab 0x280000 Offset bis zum Ende ist so einiges abgelegt !
Hier sind MAC, Seriennummer und Hardware-Konfiguration in geschützten Sektoren verankert,
und ich vermute, dass diese Teile mit dem Security-Board zusammen spielen müssen !
Geschützt heißt hier nur 'schreib-geschützt' !

Das mit 'überhaupt nicht booten', stimmt soweit auch nicht ganz.
Es wird zumindest der Bootloader aus dem NOR entpackt, ins DRAM geladen und das Linux aus dem NAND geladen.
Wo die Kiste dann das Security-Board über USB einklinkt habe ich noch nicht untersucht.

Murphy-09

10

Freitag, 11. April 2014, 09:19

@ Murphy-09

Hälst du das hier für praktikabel:

Klick
2x ET 9200 - 1x ET 6000

11

Freitag, 11. April 2014, 09:50

Security-Board

index.php?page=Attachment&attachmentID=3963Also wie man die Batterie tauscht ist eigentlich egal.
Ich habe das Security-Board untersucht und festgestellt, das Backup-Pin des ST-Controllers, also wo die Batterie hinführt, über eine Doppeldiode angeschlossen ist.
Die eine Diode geht zur Batterie, die andere zur Versorgung der Platine.
Wenn man nun das Security-Board versorgt, also die Box eingeschalten hat, kann man die Batterie ohne Probleme entfernen.
Es ist eben nur ein wenig gefährlich am 'offenen Herzen' zu arbeiten.
Wenn einem da was auskommt oder/und was in die Kiste fällt ist schnell mehr kaputt, als die Aktion wert war.
Deshalb bevorzuge ich die zweite Methode, also das Security-Board auszubauen und fremd zu versorgen.
In diesem Modus läuft auch der ST-Controller nicht und das ganze Board ist 'ruhig'.
Nun kann man ohne Probleme eine externe Batterie anlöten, die Eingebaute rauszwicken, sofern nicht gesockelt, die Lötpins entfernen und einen Sockel oder eine Neue wieder einlöten.
Ganz Batterie-Neurotische können sich natürlich auch gleich zwei Sockel einbauen, um die Batterieaktion öfters zu praktizieren.
Die Sache mit den Sockeln habe ich bei älteren Kisten mal untersucht und festgestellt, das die Batterie zwar in Ordnung war, aber der Kontakt unter der Batterie so oxidiert war, dass eine Verbindung nur noch zufällig bestand. Diesen Federkontakt sieht man jedoch erst, wenn man die Batterie herausgenommen hat. Vermutlich hat Xtrend deshalb auf eingelötete Batterien umgestellt.
Meiner Meinung nach reicht es alle 6 Monate mal die Spannung zu messen und wenn sie unter 2.9V gefallen ist, ist die Batterie auf dem absteigenden Ast und man sollte mal an einen Wechsel denken.
Um die Kontaktprobleme am Sockel zu umgehen, sollte man VORSICHTIG an der Diode messen. Die Seite der Diode mit einem Pin ist der Ausgang zum ST-Controller (siehe Bild)

Murphy-09 ;)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Murphy-09« (11. April 2014, 10:35)


12

Freitag, 11. April 2014, 10:03

Danke Murphy, wie immer große Klasse! :thumbsup:

PS: welches Bild? ;)
2x ET 9200 - 1x ET 6000

13

Freitag, 11. April 2014, 10:53


Meiner Meinung nach reicht es alle 6 Monate mal die Spannung zu messen und wenn sie unter 2.9V gefallen ist, ist die Batterie auf dem absteigenden Ast und man sollte mal an einen Wechsel denken.
Um die Kontaktprobleme am Sockel zu umgehen, sollte man VORSICHTIG an der Diode messen. Die Seite der Diode mit einem Pin ist der Ausgang zum ST-Controller (siehe Bild)

Murphy-09 ;)
Sie meinen denke ich eher wann Spannung unter 2.1/ 2.2V ist.
Die batterie ist 3V und was ich verstehen ist biss 1.8V noch gut.

Die ersten batterien (Wieder mehr dann 3 jahr) sind jetzt rund 2.85V und sind nicht gebraucht in ein box.
Ich denke das keiner jemalls batterie Austausch must.
Wie sie sagen mit Doppeldiode wurden die batterie nicht gebraucht wann box an steht.
De batterie arbeitet allein wann box von spannung ist. Das bedeutet, wann box an spannung ist das es noch viel langer mit geht.
X B M C


:rolleyes: :rolleyes:

14

Freitag, 11. April 2014, 11:04

@ ET-Support

Klick
2x ET 9200 - 1x ET 6000

15

Freitag, 11. April 2014, 11:35

Tja, das ist wohl theoretisch richtig mit den 2.1V, aber wenn die Zelle neu ist, hat sie ca.3.2V oder auf alle fälle mehr als 3.0V.
Mit 2.9V ist das sicher etwas übervorsichtig, aber wenn die Zelle bei 2.6V ist, bleibt nicht mehr viel Zeit,
vor allem da die nachgeschaltete Diode je nach Temperatur auch noch einiges braucht.

Nebenbei habe ich auch noch mal von einem namhaften Lithium-Zellen-Hersteller einen Auszug bezüglich des Passivierungsproblems.
Das ist das Problem, dass die Zelle eine isolierende Oxydschicht aufbaut und plötzlich der Saft weg ist, obwohl die Zelle randvoll ist.
Dieser Effekt kann durch einen kurzen erhöhten Entladestrom oder durch mechanische Beanspruchung ('Klopfen') beseitigt werden.
Ein Nebeneffekt der Harddisk ist hierbei die mechanische Erschütterung des Gerätes, was zu mindest bei nicht allzu ruhigen Platten,
den Passivierungseffekt ebenfalls beseitigt.

Leider ist der Auszug in Englisch, aber ich hoffe das man es verstehen kann:


Prevention of passivation and cell depassivation
In case of expected long (> 3 years) and high temperature (> 30° C) storage periods, it is
advisable, to apply to the batteries, every 6 or 12 months, » 5-10 second depassivation
sequences by connecting the batteries to resistors of the type mentioned in Table 1. This
type of precaution treatment should allow to :
- verify the correct voltage response of the products,
- erase or at least disturb/fragilize the passivating layer in order to facilitate the future
voltage recovery of the battery at the time of activation.

The temperature of the cell during test treatment should not exceed +30°C and also,
preferably, should stay within 0/+15°C during the 3 hours following the test, in order to allow
the appropriate building up of a new (and mild) primary passivation layer.
The occurrence of passivation during the extended use of liquid cathode cells is also a
possibility when temperatures excursions above +30° C, eventually coupled with pulses
spaced by more than 10 minutes are part of the customer's specification.


Das nur so zur Info, dass ich mir so einen höchst unglaubwürdigen Effekt nicht aus den Fingern sauge.

Falls jemand noch mehr darüber hören möchte, lasst es mich wissen....

Murphy-09 8o

16

Sonntag, 13. April 2014, 16:09

Lötet doch einfach 2 von diesen: http://www.reichelt.de/Batteriehalter-fu…=2&GROUPID=4260 parallel und wecvhselt alle 6 Monate eine der beiden aus.

17

Sonntag, 13. April 2014, 17:50

Nun kann man ohne Probleme eine externe Batterie anlöten, die Eingebaute rauszwicken, sofern nicht gesockelt, die Lötpins entfernen und einen Sockel oder eine Neue wieder einlöten.

Schon mal in Erwägung gezogen ,das nicht alle Elektronic studiert haben und nicht jeder über Kenntnisse verfügt
solche Fummelei durchzuführen! Sicher sind einige User mit Umgang Lötkolben u.s.w bewandert ,aber es ist doch nicht
von jedem zumutbar in ein elektronisches Gerät zu werkeln.

18

Sonntag, 13. April 2014, 18:03

Hi Diddi,



Ich kann Dir nur zustimmen !

Kochbücher sind für Leute, die wissen, wo beim Herd hinten und vorne ist.

Für alle Anderen gibt's da nur zwei Möglichkeiten.

Lernen oder machen lassen, aber keinesfalls ohne Ahnung 'rum werkeln'

:)

19

Sonntag, 13. April 2014, 18:23

Trotzdem anerkennend wie Du versuchst zu helfen ;)

20

Sonntag, 13. April 2014, 19:01

Lötet doch einfach 2 von diesen: http://www.reichelt.de/Batteriehalter-fu…=2&GROUPID=4260 parallel und wecvhselt alle 6 Monate eine der beiden aus.


Also wenn bei dem nächsten getauscht wird (demnächst fällig), wird einfach eine CR1/2AA oder CR1/3AA Lithiumzelle eingelötet, dann ist Ruhe.
*** ET6000 defekt ..... Dank der tollen Garantie in nur 11 Wochen repariert ;( ***

Zurzeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Ähnliche Themen