Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Xtrend Support Forum - www.xtrend-home.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 22. Dezember 2016, 14:48

92x00 bootet nicht (UNC read error occurred)

Hi,
Image lässt sich aufspielen, nach Neustart im Display 92x00 und bootet nicht.

Netzteil alle Spannungen: ok
Security Bord Batteriespannung: über 3,2 Volt
Bootloader und Image: alle Möglichkeiten durchgespielt (alten Bootloader UBIFS mit Original Image, neuen Bootloader mit OPenPLI, usw)

Fehlermeldung:

Loader:elf Filesys:raw Dev:nandflash0.kernel File: Options:(null)
Loading: 0x80001000/8124544 !!!!! UNC read error occurred, while reading from NAND flash -1
0x807c0880/172176 Entry address is 0x80600e20
TP1 Entry Address at 0x80000ffc = 80600e20
Starting program at 0x80600e20

**Exception 32: EPC=80600E20, Cause=00008028, VAddr=00000000
RA=8700C2F0, PRID=0002A044

0 ($00) = 00000000 AT ($01) = A0000000
v0 ($02) = 00010000 v1 ($03) = 00000040
a0 ($04) = 87055870 a1 ($05) = 00000000
a2 ($06) = 8700C364 a3 ($07) = 43464531
t0 ($08) = 80600E20 t1 ($09) = 8000FFC0
t2 ($10) = FFFFFFC0 t3 ($11) = 870989B4
t4 ($12) = 00000001 t5 ($13) = 8709E242
t6 ($14) = 8700C9CC t7 ($15) = 3EA95587
s0 ($16) = 8700C2F0 s1 ($17) = 87010000
s2 ($18) = 00000000 s3 ($19) = 8704DF30
s4 ($20) = 8714FD88 s5 ($21) = 87098DC8
s6 ($22) = 8714FD30 s7 ($23) = 87016828
t8 ($24) = 00000101 t9 ($25) = 87098A0C
k0 ($26) = 8709AE28 k1 ($27) = 00000000
gp ($28) = 87055870 sp ($29) = 8714FBE8
fp ($30) = 87032790 ra ($31) = 8700C2F0


*** Waiting for system reset ***


Ist der NAND Flash defekt?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »samir« (22. Dezember 2016, 15:29)


2

Donnerstag, 22. Dezember 2016, 17:39

...scheint wohl ein "uncorrectable-error" im Bootsektor des NAND-Flash zu sein. Normalerweise können Sektoren in der Bad-Block-Table markiert und ausgelagert werden. Passiert so was im Bootsektor wird schwierig. Es soll schon manchmal geholfen haben die verschiedensten Images hintereinader aufgespielt zu haben, also mit jeweiliegn Löschen und Programmieren des Flashs. Es ist auch möglich den CFE-Bootloader mittels ^C beim Sartup anzuhalten und entsprechend der möglichen Kommandos des CFE das Flash komplett zu löschen. Den Bootloader würde ich in keinem Fall anfassen. Wenn da was schiefgeht ist die Box tot. Solange der Bootloader läuft, ist das die halbe Miete.

Murphy-09 ;)

3

Donnerstag, 22. Dezember 2016, 19:17

Hi Murphy,
ich habe in den letzen Tagen bestimmt 10x den Bootloader aufgespielt. Glück gehabt.
CFE beim Starten anhalten und dann welche Befehlsfolge?

Gruss Samir

4

Donnerstag, 22. Dezember 2016, 21:40

..hab' den CFE auch schon lange nicht mehr benutzt, aber gib' einfach mal HE oder HELP ein, dann müssten alle Commands aufgelistet werden.

Murphy-09 ;)

5

Freitag, 23. Dezember 2016, 01:46

Danke für die schnelle Hife,
das habe ich nach help angezeigt bekommen:
flash -forceerase
Ist das der Befehl um den Flash komplett zu löschen?
Kann ich nach dem Löschen das Image wieder mit dem USB-Stick aufspielen?

6

Freitag, 23. Dezember 2016, 10:10

...langsam, langsam....
gibt der Help nicht mehr her ?
Nicht dass Du das NOR-Flash löschst, also den Bootloader, das wär fatal !!
Es darf nur das Nand-Flash gelöscht werden.
Wenn Du das so nicht rauskriegst, lieber auf die mehrfach-Image-Aufspielmethode zurückgreifen.
Evtl. weiß ja ein anderer im Forum das NAND-FlASH ERASE Command.
Falls das allerdings nichts hilft, muss ein neues NAND-Flash rein.
Das Teil hängt direkt auf der Board-Unterseite unter dem NOR-Flash.

Murphy-09 ;)

Ähnliche Themen