Sie sind nicht angemeldet.

1

Mittwoch, 18. Januar 2017, 12:31

Lsp5502-Lsp5503

Nachdem immer mehr fähige Leute versuchen, andere sollten es NICHT, die Mainboard-Wandler zu tauschen, mache ich hier mal eine Anleitung für den Ersatz des LSP5502 bzw. LSP5503 durch den Texas-Instruments Typen TPS5432.
Die Beschreibung hierfür bezieht sich auf den 3A, 1.2V Core-Spannungwandler direkt neben dem Lüfterstecker.
Bei den anderen Wandlern auf dem Board sind natürlich auch andere Bauteile für den TPS5432 nötig !

Der Liteon Wandler LSP5502 bzw. 5503 hat eine Schaltfrequenz von ca. 400kHz.
Dadurch wird die Größe der Spule definiert, also der grünen Tonne neben dem Chip.
Steigt die Wandlerfrequenz, käme man mit einer kleineren Spule aus, oder man belässt die große Spule und erhält den Vorteil einer sauberern Spannung, also weniger Ripple.
Der LSP5503 hat auf der Chip-Unterseite eine Substartplatte, die mit der Platine verlötet ist.
Der LSP5502 hat diese Platte nicht, jedoch auch weniger Leistung.
Ein LSP5502 kann ohne Probleme und auch ohne Verlöten der Platte durch einen LSP5503 ersetzt werden.
Hierbei brauchen auch keine anderen Bauteile geändert werden.
Wer kann, sollte natürlich die Platte des LSP5503 immer verlöten.
Falls das nicht möglich ist, eignet sich auch ein kleiner Tropfen Wärmeleitpaste unter dem Chip, um die Wärme besser in die Platine abführen zu können.
Das ist zwar besser als garnichts, aber wer verlöten kann, sollte dies auch tun.

Wer nun den LSP nirgends auftreiben kann, kann einen wesentlich besseren Texas Typen einsetzen.
Leider sind die Parameter des TPS5432 geringfügig unterschiedlich, aber das Gehäuse und das Pinning sind absolut identisch.
Der Hauptunterschied liegt in der Feedback-Spannung, also der Spannung, auf die der Chip versucht auszuregeln.
Der LSP hat hier 0.925V, der TPS möcht gerne 0,808V.
Hierzu ist auf dem Board ein Spannungsteiler mit zwei Widerständen realisiert.
Im Original des 1,2V Core Reglers sind hier 10K und 3K verbaut, Aufschrift 01C und 302, Markierung R21 und R19)

Der Vorteil in jedem Fall, alle Bauteile liegen auf der Oberseite, d.h. man muss das Mainboard nicht ausbauen.
Vorsicht ist natürlich beim Sec-Board angebracht, das ich für die gesamte Aktion ausbauen und sicher verwahren würde.
Erste Versuche und Messungen nach dem Tausch mache ich auch ohnedas Sec-Board.
Erst wenn die Kiste wieder bootet wird das Sec-Board wieder eingebaut.

Je nach Möglichkeit und Zugriff auf entsprechende Bauteile kann man nun verschiedene Weg gehen.
Wer Bauteile hat, Rs und Cs, kann ale Bauteile wie im Datenblatt des TPS5432 einbauen, um den Wandler möglichst effektiv zu machen.
Wer nur minmale Änderungen machen möchte, kann sich nur an den Teiler wagen und dort entweder die Widerstände tauschen oder einen Passenden über den bereits Vorhandenen löten.
Wichtig ist nur, dass das Teilerverhätnis für den TPS5432 stimmt.
De TPS5432 benötiget im Idealfall ein Verhältnis von 1:2,06 wobei 1:2 ausreichend wäre.
Widerstandkombinationen von 3K3/6K8 oder 10K/20K wären geeignet.
Man kann natürlich den bereits vorhandenen Teiler so ändern, das man nur einen Widerstand benötigt.
Der vorhandene Teiler hat 3K0/10K und kann mit einem 16K parallel auf den 10K gelötet zu 3K0/6K15 gemacht werden.
Bei 15K parallel auf den 10K kommt man auf 3K/6K und einer Spannung von 1,212V, was auch noch ok ist.
Wer einen 4K87 Widerstand an Stelle des 3K0 Widerstandes lötet, hat somit einen Teiler von 4K87/10K und einen Spannung von 1,20V.
Der Baustein ist relativ gutmütig, wodurch man die Kompensationswerte nicht unbedingt ändern muss.
Der Softstart ist ebenfalls völlig unkritisch und kann so belassen werden.

Bitte die Widerstandswerte lieber 5x überprüfen !
Die CPU verträgt im absoluten Maximum 1,32V, darüber ist die Box gut für die Rundablage !!!!
Eine Fehlspannung von wenigen Millisekunden kann die Box killen, also vorsichtig und sorgfältig arbeiten !
Nach Einbau mit Multimeter auf Kurzschlüsse Prüfen ?
Hat der Masse Pin 4 Null Ohm zu Ground ?
Hat der Versorgungs Pin 2 Null Ohm zum 5V Pin des Netzteils oder der anderen LSP Wandler?
Kein anderer Pindes TPS5432 darf niederohmig zu GND oder 5V sein, sonst stimmt was nicht.

Wer ganz sicher gehen will kann den Wandler auch erst mal ohne Einspeißung ins Board testen.
Hierzu muss man allerdings die Spule (grüne Tonne 4R7) einseitig auf Seite des Becherelkos ablöten und mit einen anderen Elko ähnlicher oder größerer Kapazität verbinden.
Der Widerstand (Markierung R19 auf dem PCB), der derzeit Pin5 mit den 1.2V der Platine verbindet wird dann ebenfalls entfernt und zwischen Spule und Pin5 des Wandler verdrahtet.
Der neue Elko wird mit Ground verbunden und nun kann man die Box versorgen und schauen, welche Spannung sich am Elko einstellt.
Sofern hier keine 1,2V zu messen sind, war der Umbau nicht erfolgreich !
Falls die 1.2V o.k. sind, wird die Spulle wieder normal verlötet und die Sache hat sich.

Der TPS5432 benötigt an Pin1 ein 100nF Boost-Kondensator und der LSP hat hier nur einen 10nF verbaut.
Dies ist allerdings kein Problem und es müsste auch mit 10nF laufen.
Leider ist dieser Kondensator auf der Mainboard-Unterseite.
Wer will kann einen 100nF Keramikkondensator einfach zwischen die Pins 1 und 3 auf der Oberseite löten.
Hierzu geht auch ein einfacher bedrahteter Scheibenkondensator.
Der 10nF auf der Unterseite stört nicht und kann bleiben.

Ansonsten:
Pin 1 des Wandler-Chips beachten !
Achtung ! Dieser Ersatz gilt nur für Wandler die mit 5V Eingangsspannung laufen !
Der LSP5502/3 verträgt bis zu 30V Eingangsspannung.....der TPS5432 maximal 6V !!!!!
Bei anderen Boxen mit externem 12V Netzteil kann der TPS5432 nicht an den 12V betrieben werden !!!

Über die sonstigen Vorsichtsmaßnahmen beim Arbeiten am offenen Gerät muss ich mich ja nicht weiter auslassen,...
Diese Umbauten sollte nur jemand machen, der weiß, was er tut !!!

Murphy-09 ;)
»Murphy-09« hat folgende Dateien angehängt:

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Murphy-09« (18. Januar 2017, 12:49)


2

Mittwoch, 18. Januar 2017, 18:52

:thumbsup:

Schön gemacht murphy, wenn es Jemand eilig hat durchaus eine Option. Und derjenige der sich ran traut, wird hoffentlich wissen was er macht und mit der Anleitung auch zurecht kommen.

Allen anderen würde ich persönlich jedoch empfehlen die Lieferzeit in Kauf zu nehmen und den LSP 1:1 tauschen.
*** ET6000 defekt ..... Dank der tollen Garantie in nur 11 Wochen repariert ;( ***

3

Dienstag, 24. Oktober 2017, 07:42

Lieber Murphy-09

vielen Dank für deine Mühe, ich habe vergeblich gesucht, um diesen thermischen Fehler zu finden, bestimmt 2 Kältespraydosen verpulvert :cursing:
Dachte erst an kalte Lötstelle, Ground vielleicht
Ich hatte auch die 4 BGA`s in der Nähe des Steckers zum Netzteil im Verdacht und mit Flussmittel und Heißluft und Heizplatte versucht,sie zu rebaldern, leider ohne Erfolg 8|
Auch die Elkos im Netzeil habe ich gemessen und getauscht leider ohne Erfolg
Was ist mit den anderen Spannungsreglern in der Nähe des LSP5503 , können die auch zu Problemen führen und sollte ich die vorsorglich mittauschen, sind ja Cent Bauteile.
Wahrscheinlich war mein Fehler gewesen , den Reciever(Tochter) immer ganz stromlos zu machen wenn wir wegfuhren, oder wenn ich mich darüber mal wieder ärgern musste dass sie ihn anließ , einfach aus der Steckdose rauszog :whistling: :whistling:

Ich warte mal auf deine Antwort , bevor ich den LSP5503 bestelle

Liebe Grüße

4

Dienstag, 24. Oktober 2017, 08:19

.....ausschalten ist immer besser als im Standby laufeb lassen, schon wegen der Umwelt.
Im Fall des DeepStandby ist das Hauptnetzteil sowieso aus, also ist es fast egal ob ganz aus oder nur blaue Led.
Das Netzstecker ziehen kann höchsten den Inhalt des NAND Flash zerstören.
Da der Booter aber im NOR ist, kann man die Sache meinstens wieder neu flashen.

Welche anderen Regler um den LSP sind denn gemeint ?

Welcher LSP ist gemeint ?

Vor dem Tausch bitte die Spannungen am LSP messen !

Murphy-09 ;)

5

Dienstag, 24. Oktober 2017, 08:39

Hallo,

ich glaube für die 1,8 V gibt es auch einen , also in der Nähe des Steckers zum Netzteil sind 3 dieser IC´s habe die Bezeichnung nicht muss erst heute Abend nachsehen
Also der Reciever fährt hoch , wenn ich mit dem Fön diesen Bereich erwärme.
Wenn ich den Reciever einschalte und er nicht hochfärht, ihn dann mit dem Fön erwärme , fährt er ja nicht hoch, erst nach Powercycling

6

Dienstag, 24. Oktober 2017, 17:13

Hallo Murphy-09

ich habe die Spannungen an den beiden Spulen für 1,2 und 1,8 V gemessen.
Die 1,2 V sind da aber die 1,8V fehlen
Wenn ich mit dem Lötkolben den U1(LSP5502) erhitze , hab ich an der Spule 1,8V und der Reci schaltet sich ein.
Der U1 hat ja den LSP5502, kann ich da auch den LSP5503 einlöten?
Ich frage , weil ich noch eine ET9500 habe und ich ein 5-er Pack LSP5503 bestellen will, um im Fall der Fälle auch die 1,2V reparieren kann und die 2-te 9500 natürlich
Soweit ich dem Datasheet entnehmen kann ist die letzte Zahl LSP550(2)(3) die Ampereleistung , die der Chip aushalten kann.

LG

7

Dienstag, 24. Oktober 2017, 21:43

...kein Problem, der 5503 hat wie gesagt nur ein "exposed pad" unten.
Das macht aber nichts, das muss nur im Falle der höheren Leistung verlötet werden.
Ein wenig Wärmeleitpaste unter den Chip, reicht völlig aus und schon hält er wesentlich länger als der 5502.

Murphy-09 ;)

8

Dienstag, 24. Oktober 2017, 21:48

Danke für deine Hilfe,
melde mich , wenn die Chips aus Fernost da sind und eingelötet

Gruß :thumbsup:

Ähnliche Themen