You are not logged in.

Dear visitor, welcome to Xtrend Support / GigaBlue Info. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, December 28th 2014, 1:24am

Problem mit D-Link DWA-140 USB WLAN Stick

Hallo Zusammen,

ich habe das Problem, dass der D-Link DWA-140 USB WLAN Stick an meinem ET10000 (Openpli v. 27.12.14) nicht richtig funktioniert.

Der Stick wird zwar erkannt (rt2800) bekommt aber nach der Eingabe der Zugangsdaten für den Access Point keine Verbindung (grüne LED).

Es handelt sich vermutlich um ein Treiber Problem.

Scheinbar gibt es den Stick in verschiedenen Ausführungen.

DWA-140 B1 Ralink chipset RT2870
DWA-140 B2 Ralink chipset RT3070
DWA-140 B3 Ralink chipset RT5370
DWA-140 D1 Ralink chipset RT5372

Es handelt sich um einen D-Link DWA-140 rev D1 (RT5372?).


Eigentlich sollte ja das Treiber Modul rt2800usb ab Kernel 3.13 funktionieren. Tut es aber leider nicht.

Alternativ könnte wohl das Kernel Modul rt5370sta funktionieren, habe ich aber für die ET10000 nicht gefunden. Leider auch nicht die Quellen um diese durch den Compiler zu jagen.

Source code

1
2
3
4
5
opkg update
opkg remove --force-removal-of-dependent-packages kernel-module-rt2800lib
opkg remove --force-removal-of-dependent-packages kernel-module-rt2800usb
opkg remove kernel-module-mac80211
opkg install kernel-module-rt5370sta 


Hat leider nicht funktioniert da es das rt5370sta Modul im Openpli-Feed nicht gibt.

Hat jemand noch eine Idee wie man den o.g. Stick zum Laufen bekommt?

Gruß starbuck
Xtrend ET10000; 4xDVB-C Tuner (A: TDA1024, B: TDA1024, C:TDA1024 , D:Si2169); 1.5 TB HDD, Firmware: aktuelles OpenPLI 4.x