Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Xtrend Support / GigaBlue Info. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

21

Dienstag, 12. November 2013, 05:51

Also mal so,ich nutze ATV habe aber mal kurz das neueste PLI 4 geflasht und ich brauche kein zusätzliches Passwort
in Telnet eingeben um Zugriff auf FTP zu haben ! Bei FTP gebe ich in Server die IP der Box ein und Benutzername root dann
auf verbinden und das wars.
Um Webif zu öffnen ebenfalls kein Problem IP Adresse der Box in Adresszeile eingeben und schon bist Du im Webif.
Unter Netzwerk mal schauen ob sich die IP der Box geändert hat,deshalb habe ich DHCP auf nein gestellt.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »diddi« (12. November 2013, 06:00)


22

Dienstag, 12. November 2013, 11:15

Hallo asterix,

zur Frage nach BrowserTool anstatt OpenWebIF: "Browsertool" gibt es keines, die Verwaltung der Bouquets und Sortierung der Sender kannst Du mit dreamboxedit oder dreamset am besten machen.

Die Fehlermeldung oben sagt mir nichts, vielleicht gab's da gerade im Nightly-Build ein Problem. Du könntest aber versuchen das OpenWebIF zu deinstallieren und nach einem Restart (zumindest der GUI) neu zu installieren. Oder mal ein paar Tage lang eine System-Aktualisierung vornehmen.

Grüße
Hounce

23

Dienstag, 12. November 2013, 18:06

Hallo nochmal,

Dein Fehler war schon gestern bei OPEN PLi bekannt und ist bereits gefixt, siehe PLi Forum.

Im beigefügten ZIP-File, welches ich aus oben verlinktem Thread des PLi-Forums habe, findest Du die Datei base.py, welche Du nach /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers kopieren musst. Nach Neustart der GUI sollte das OpenWebIF wieder gehen.

Grüße
Hounce
»hounce« hat folgende Datei angehängt:
  • base.zip (2,3 kB - 4 mal heruntergeladen - zuletzt: 13. November 2013, 20:07)

24

Dienstag, 12. November 2013, 21:38

Hallo hounce,
na die Ursache wäre geklärt. Nun etwas banales, und ich könnte mir zwar das Hemd zerreissen ,
so etwas einfaches wie ,Datei vom Stick ins Verzeichnis, bekomme ich aber nicht gelöst.
Also die Datei habe ich ausgepackt und auf dem Stick. Aber wie bekomme ich die dusselige Datei vom Stick ins Verzeichnis ?
Gemountet wird offensichtlich nach dem einstecken automatisch, weiß ich weil ich mit dem (mount Befehl) noch eine zusätzliche verbindung gebaut habe.
Ich wollte nun ,ala Windows, auf den Stick und hier mit dem copy befehl (cp [DATEI1] [DATEI2]) die datei in das Verz. kopieren.
Aber eher habe ich Streifen in der Hose.
Sei bitte so freundlich, für einen Anfänger :
1..
2
3
sorry, ich habe jetzt etliche Unix Befehle drauf aber nicht wie ich kopieren soll. Geht das auch vom PC auf die stb ?
gruß
asterix

25

Dienstag, 12. November 2013, 21:42

Hallo diddi,
werde ich ausprobieren sobald ich meine Kiste wieder halbwegs zum Laufen gebracht habe und eine Sicherung auf dem Stick habe.
Vielen Dank
gruß
asterix

26

Mittwoch, 13. November 2013, 10:32

Hallo asterix,

nachdem Du ja mit telnet auf die Maschine kommst, kannst Du auch gleich mittels geeignetem FTP Programm kopieren, z.B. WinSCP oder FileZilla. Zugangsdaten sind gleich wie für telnet also "root" und Dein Passwort.

Wenn Du es mit der Kommandozeile machen möchtest, ist Dein Ansatz von oben absolut korrekt, der Befehl würde z.B. lauten:

cp /media/usb/base.pyo /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers

unter der Voraussetzung, dass der USB-Stick bei Dir nach /media/usb gemountet wird, was Du einfach mit dem Befehl "mount" überprüfen kannst.

Zusätzlich gibt es noch die Plugins Tux-Kommander (2 Bildschirmbereiche ähnlich zum Uralt-Norton-Commander, falls Du den noch kennst) und DreamExplorer, welche das Kopieren mittels Fernbedienung erlauben.

Meiner Ansicht nach solltest Du den Ansatz mit FTP verfolgen, das ist das einfachste und schnellst und wird Dir sicher noch öfter zugute kommen.

Grüße
Hounce

27

Donnerstag, 14. November 2013, 01:05

Hallo Hounce,
hat nicht geklappt mit dem cp Befehl :
root@et9x00:~# cp /media/INTENSO/base.py /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers
cp: can't stat '/media/INTENSO/base.py': No such file or directory

Wie sieht es denn neben TuxKommander mit Dreambox Tools aus zB. DCC sieht auch ziemlich gut aus, oder ist das nix für xtrend ?
mfg
asterix

28

Donnerstag, 14. November 2013, 11:11

Hallo asterix,

DCC geht natürlich auch, ebenso wie FileZilla oder WinSCP.
Ansonsten sagt die Fehlermeldung klar, dass die Quell-Datei nicht dort steht, wo Du sie erwartest, weshalb sie nicht kopiert werden kann.

Dem DOS "dir" entspricht auf LINUX das Kommando "ls", damit kannst Du mal schauen, z.B.:
ls -l /media/INTENSO

Oder Du läßt suchen, z.B.:
find /media/INTENSO -name "base.py"

Grüße
Hounce

29

Samstag, 16. November 2013, 10:31

Hallo hounce,
ersteinmal vielen Dank für die Tipps.
winscp hatte ich gerade ausprobiert. Sieht wie Windows aus. Akzeptiert aber nur FTP.
Bei den anderen Protokollen will er das bekannte PW nicht akzeptieren.

Muß ich auf dem xtrend noch eine bestimmte Freigabe generieren ???
Gilt das auch für DCC ???

Ich vermute, ich muß als erstes die Verzeichnis- und Namensstruktur in linux begreifen damit ich mich weiter durchwursteln kann.
Mein Problem habe ich mit einem Update gelöst, denn das Prob war bekannt und gefixt(hast du geschrieben) also sollte die falsche Dateie über diesen weg auf die stb kommen, was auch geklappt hat.
(heute habe ich endlich mal ein wenig Zeit für die Box)
nochmals vielen Dank.
gruß
asterix

Ähnliche Themen