You are not logged in.

Dear visitor, welcome to Xtrend Support / GigaBlue Info. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Wednesday, November 22nd 2017, 2:41pm

ET4000 not booting up!!!


I had my Xtrend ET4000 left in deep standby and when i came to turn it on, its not booting up, red and green light on and nothing is happening.
I Left it over night and it was still the same. So the I tried installing a new image, buy following the usual procedure
1- Format USB to FAT32
2- Download image and extract and place ET4x00 folder on root of USB.
3- Power off box, (even took power cable out), plug in USB, plug in cable and turn the box on (tried both front and back USB ports)
4- Tried "force" and "noforce" way
nothing else is connected to the box, but it seems that its not booting to recognise the USB and image.
I tried couple of other USB sticks and no joy
Have had this box for about 4 years now, is it time to invest in a new box!? or can someone help me bring this box back to life.

Thanks for your help in advance


Wednesday, November 22nd 2017, 4:15pm

Try to rename the folder to et4x00 or et4000.


Thursday, November 23rd 2017, 2:21pm

I have tried that, no luck.
It seems the box does not load far enough to process attached USB and process the files.
Red and green line constantly on :( :(