You are not logged in.

Dear visitor, welcome to Xtrend Support / GigaBlue Info. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Pedro_Newbie

Unregistered

1

Thursday, May 31st 2012, 3:03pm

BackupSuite for Openpli 3.0 version > 10

For Openpli 3.0 or later

Here's the latest version of the plugin BackupSuite, suitable for Openpli 3.0 or later/ Open Embedded 2.0.

In this first post you'll always find the latest public version of the BackupSuite for Open Embedded 2.0.

The BackupSuite is capable of making full back-ups of a running system. The back-up contains all files and settings as they are on the system at the moment of making the back-up.
In case of emergency or any other mishap you are capable of restoring your system in a matter of a few minutes (< 5 ).

The BackupSuite can back-up:
All the models supported by Openpli except Dreamboxes and many more (to come)

After installation* you will find an entry in the Menu under: Menu -> Plugins -> BackupSuite
(or in German Menu -> Erweiterungen -> BackupSuite)
* Installation has to be done with a working internet connection to be able to fetch the required package mtd-utils from the feed)

Backup > HDD
This option makes a back-up directly to a harddrive (or NAS).
This option does provide an extra option namely copy the made back-up directly from HDD to an USB-flashdrive. If you place a valid USB-stick, as mentioned here under Backup-> USB, before or during the back-up process then the made back-up will also be copied to this drive at the end of the process.

Backup > USB
This option makes a back-up directly to an USB-flashdrive, however there is one condition that has to be fulfilled and that's there MUST be a file on the USB-flashdrive with the name backupstick or backupstick.txt or whatever name containing the word backupstick. So a file with the name: hands_off_this_is_my_backupstick.txt is also valid! It doesn't matter if UPPER- or lower-case letters are used or even a mix of those 2.
This back-up will be written on 2 places, one in the folder representing the modelnumber e.g. ET9x00 and in a folder with the name fullbackup_et9x00, this is your archive of all back-ups made directly to this USB-flashdrive.

Restore backup
With this option you are able to restore a backup or flash a new image directly from your harddisk, NAS or USB-stick or any other mounted device.

What's new
Shows the changes in the plugin since the last version

The supported languages are now: English (default), Dutch, French, German, Greek, Italian, Polish, Russian, Slovak, Spanish, Swedish and Turkish.

Here are some screenshots
Startscreen and start backup process to harddisk

Second and third screen of the backup process

A screenshot of the restore process, choosing the desired backup to restore and the question what part (or all parts) to restore

The "What is new since the last version" screen and the error report you will see if you try to make an USB backup without a valid USB-stick inserted

The first page of the helpfile

Again for Openpli 3.0 or later / Open Embedded 2.0 only
Please don't try to use this version in the "older" images 2.1, the used programs/versions are not compatible

Complete changelog version 18.0(a)
30-08-2014
- Added Swedish translation. Big thanks goes to H2SO4JB (on Openpli)

28-08-2014
- Added support for the ET8500 (a bit premature, but what the heck)

19-08-2014
- Add a list of all installed packages in the logfile. This should make it easier if you want to find a specific backup with e.g. certain driver versions.
- Report the driver version in the logfile at the start of the backup process

15-8-2014
- Completed some translations needed for the MessageBox when starting to make a backup

14-08-2014
- Added messagebox to confirm the start of the backup process of the HDD and USB option
- Added support for the Xtrend ET7000 and ET7500
- Added support for the Mutant/Opticum HD2400 and the Mutant HD1100
Pedro_Newbie has attached the following file:

This post has been edited 133 times, last edit by "Pedro_Newbie" (Aug 31st 2014, 8:16am) with the following reason: Added version 18.0a


Pedro_Newbie

Unregistered

3

Wednesday, August 8th 2012, 9:16am

updated the first post with version 10.4

XtrendIM

Administration+Technik+Support

Posts: 3,696

Location: Europa

  • Send private message

4

Wednesday, August 8th 2012, 9:24am

Thx, Pedro_Newbie!
Ihr Xtrend Support-Team
eXtrending your vision

Pedro_Newbie

Unregistered

5

Sunday, September 23rd 2012, 8:03pm

In post #1 there is the new version of the BackupSuite, now version 10.5 of 23-09-2012.
This update was necessary for the USB option of the BackupSuite.
Openpli has today changed the method of mounting the USB-devices, this has as side effect that the USB only version wasn't working any more.

I made some changes and now you should be again able to run this option. Please test it, I'm not 100% sure if this solution will work all the time.

Some information about the mounting

Quoted from "Milo from Openli"

Starting today, OpenPLi 3.0 will no longer default to mount USB sticks and similar devices as "/media/usb". Instead, it uses the LABEL of the disk as mount point name. This is similar to what Ubuntu does when you insert a stick.

The result may be that your USB device is no longer available on the spot where it used to be, in particular when using it for recording this may be a nuisance.

On the bright side, it can make mounting multiple USB disks much easier. Examples:

- A factory-formatted sandisk stick will probably be mounted as "SANDISK" or something similar.
- To have your USB disk mounted as /media/hdd, just label the disk "hdd" (use tune2fs to set the label of an EXT2/3/4 formatted disk).
- If you have a red USB stick, plug in in a Windows PC and rename it to "Red". Insert it into the box and it will appear as /media/Red.

Optimum Power

Unregistered

6

Sunday, September 23rd 2012, 8:36pm

Vielen Dank ! Funktioniert wie immer bestens ! :thumbsup:
Optimum Power has attached the following files:
  • pedro.png (15.49 kB - 200 times downloaded - latest: Feb 25th 2017, 3:37pm)
  • Pedro1.png (35.54 kB - 181 times downloaded - latest: Feb 25th 2017, 3:37pm)
  • pedro2.png (37.97 kB - 149 times downloaded - latest: Sep 15th 2016, 2:14pm)
  • pedro3.png (4.14 kB - 138 times downloaded - latest: Sep 15th 2016, 2:14pm)
  • pedro4.png (20.2 kB - 127 times downloaded - latest: Sep 15th 2016, 2:14pm)

Pedro_Newbie

Unregistered

7

Sunday, September 23rd 2012, 9:05pm

Thanks for the confirmation!

8

Monday, September 24th 2012, 7:02am

feed

Will these kind of updates be included in the feed or do we have to track them seperately?
Thanks
Hdtvpower
xtrend9500 openpli3.0 2TB

Pedro_Newbie

Unregistered

9

Monday, September 24th 2012, 9:49am

If everything went well it should be on the feed today. It certainly is for the Vu+ Duo. The builds of last night are online so if you do an online update it should be installed on your receiver

XtrendIM

Administration+Technik+Support

Posts: 3,696

Location: Europa

  • Send private message

10

Monday, September 24th 2012, 10:19am

Thx for your work Pedro_Newbie :thumbsup:
Ihr Xtrend Support-Team
eXtrending your vision

11

Monday, September 24th 2012, 11:14pm

The new solution seems to be name sensitive. My usual backupstick named "STORE N GO" didn´t work.
Error message: "sh: N....unknown operand"
Renamed under Win 7 to "TVSTICK" did the trick.
Renamed again to "TV STICK".
Error message: "sh: STICK/......... unknown operand"

Blanks in the name of the stick are not allowed!

Thanks for your work.

12

Tuesday, September 25th 2012, 2:41pm

Sorry, wenn ich vielleicht blöd frage, aber wie macht man denn einen Restore ???

EDIT: Ok, verstanden, wenn ich das Backup auf nen Stick mache, flashen wie immer, nur wenn ich ne HDD benutze versteh ich es nicht
xtrend 10000, xtrend 9200, xtrend 4000

This post has been edited 1 times, last edit by "Czarno" (Sep 25th 2012, 3:01pm) with the following reason: Lösung gefunden


Pedro_Newbie

Unregistered

13

Tuesday, September 25th 2012, 5:16pm

The new solution seems to be name sensitive. My usual backupstick named "STORE N GO" didn´t work.
Error message: "sh: N....unknown operand"
Renamed under Win 7 to "TVSTICK" did the trick.
Renamed again to "TV STICK".
Error message: "sh: STICK/......... unknown operand"

Blanks in the name of the stick are not allowed!

Thanks for your work.

I see the problem, I will search for a solution the coming days and will test it. It could take some days because the lack of time but I will do my best.

In the meantime don't use sticks with blanks in the name as a workaround

Thanks for your report!

Pedro_Newbie

Unregistered

14

Tuesday, September 25th 2012, 5:18pm

EDIT: Ok, verstanden, wenn ich das Backup auf nen Stick mache, flashen wie immer, nur wenn ich ne HDD benutze versteh ich es nicht


When the back-up is on your HDD you can't do much with it, it is pure for archive purposes. To restore just copy it to an USB-stick

walze

Trainee

Posts: 113

Location: Österreich

  • Send private message

15

Tuesday, September 25th 2012, 6:16pm

Ich versuche schon ganze Zeit das Plugin (backupsuite 10.2) zu installieren. Es kommt am Ende "Ausführung beendet!" Aber wenn ich dann unter Erweiterungen schaue finde ich es nicht?
Ich kann es auch nicht finden wenn ich versuche es wieder zu deinstallieren!?
Was mache ich falsch?

16

Tuesday, September 25th 2012, 7:14pm

Hast es schon mal mit der 10.5 aus Post#1 probiert?

walze

Trainee

Posts: 113

Location: Österreich

  • Send private message

17

Tuesday, September 25th 2012, 7:16pm

Ja habe ich jetzt auch versucht zu installieren. Wieder ist alles ok gekommen. Wieder nichts zu sehen bei Erweiterungen!?

Pedro_Newbie

Unregistered

18

Tuesday, September 25th 2012, 8:41pm

In post 1 there is the new version of the BackupSuite, now version 10.6 of 25-09-2012.
This update was necessary for the USB option of the BackupSuite.

This is a bugfix release. I repaired the error which caused the program to crash when one or more spaces were used in the label of the USB-stick.

I tested different possibilities/combinations and I think the error is fixed.

Have fun

Pedro_Newbie

Unregistered

19

Tuesday, September 25th 2012, 8:44pm

Ja habe ich jetzt auch versucht zu installieren. Wieder ist alles ok gekommen. Wieder nichts zu sehen bei Erweiterungen!?

Did you try to install the package with a working internet connection. A working connection is required the install the required packages.

Please try to install the package via telnet (e.g. DCC_E2). You can see the (error-)messages during install.

the commandline command in telnet is

Source code

1
opkg install enigma2-plugin-extensions-backupsuite

walze

Trainee

Posts: 113

Location: Österreich

  • Send private message

20

Tuesday, September 25th 2012, 8:50pm

wie genau geht das mit telnet?
habe ich noch nie gemacht. DCC-E2 habe ich verwende aber immer nur FTP.

Similar threads