You are not logged in.

Dear visitor, welcome to Xtrend Support / GigaBlue Info. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, December 15th 2015, 10:48pm

Keine rechte über NFS auf Openmediavault

Hallo,

Ich habe einen ET10000 und einen ET9000, beide mit Openpli 4, bei beiden habe ich ein kleines Problem mit den Netzwerkeinstellungen. Ich habe unter Menue->Einstellungen->System->Netzwerk->Lan Verbindung 2->Netzwerkbrowser den Openmediavault Server hinzugefügt. Habe in OMV einen Benutzer angelegt und den auch im ET so eingegeben. Jetzt kann ich auch darauf zugreifen und Filme davon abspielen, aber ich kann nicht darauf Aufnehmen und wenn ich mit der Konsole und

Source code

1
touch: /media/net/OMVtest/test.txt
versuche eine Datei anzulegen bekomme ich nur als Antwort

Source code

1
touch: /media/net/OMVtest/test.txt: Permission denied
.
Warum ich jetzt hier schreibe? Naja von meinem Laptop läuft das ganze Wunderbar... einfach über

Source code

1
sudo mount ipadresse:/PFAD/ZUR/FREIGABE /media/MEINEFREIGABE
und mit diesem Befehl bekomme ich beim ET aber kein anderes Ergebnis.

Jetzt Hoffe ich einfach mal, dass jemand eine ähnliche Konfiguration hat oder sich besser auskennt und mir helfen kann.

XtrendIM

Administration+Technik+Support

Posts: 3,696

Location: Europa

  • Send private message

2

Thursday, December 17th 2015, 9:06am

und mit diesem Befehl bekomme ich beim ET aber kein anderes Ergebnis.


Mounte deine Laufwerke über den Mountmanager, oder direkt die automounts.xml unter /etc/enigma2 editieren.

Sudo bringt Dich hier nicht weiter, da der komplette E2 Prozess unter root läuft .-)

Gruss
IM
Ihr Xtrend Support-Team
eXtrending your vision

3

Friday, December 18th 2015, 6:39pm

Ist der Mountmanager der Freigabemanager?
Denn dort habe ich sowohl den Server eingebunden, als auch dafür einen Benutzer angelegt, der auch in OMV auch hinterlegt ist.
Ich hatte das Laufwerk nur manuell eingebunden um zu überprüfen ob was beim Freigabemanager nicht stimmt. Und das mit sudo ist ja selbstverständlich.
Als Freigabeoptionen ist voreingestellt "rw,nolock,tcp"

bin immer noch nicht weiter gekommen...

4

Friday, December 18th 2015, 9:37pm

also ich habe das Problem etwas genauer lokalisiert... die Freigabe nimmt nicht den richtigen Benutzer... sondern root, der auf OMV keinen zugriff hat. Leider bin ich jetzt auch nicht so tief im Linux, so dass ich jetzt nicht wirklich selbst auf eine Lösung komme...

5

Friday, December 18th 2015, 10:19pm

naja evtl fällt ja jemandem noch was anderes ein, aber ich bin etwas weiter gekommen

im Openmediavault Web Interface unter Dienste->NFS->Freigaben->Bearbeiten->Erweiterte Optionen noch no_root_squash anhängen, und alles läuft, denn dadurch wird eine Datei die im ET root gehört zu anonymous.

1 user apart from you is browsing this thread:

1 guests