You are not logged in.


Sunday, March 25th 2012, 10:09am

No DTS-Sound after OpenPLi Online Update dated 25.03.2012

Dear valued Xtrend-Customers,

one importent note for you, after performing latest OpenPLi Online-Update dated 25.03.2012

If you cannot hear any Sound when Mediaplayback is started with DTS-Audiotracks, you must perform the following guide:


Logon to Xtrend-ET with telnet or SSH-Connection:

Stop running E2-GUi Process (currently active Recordings will be stopped):

1. With Command:

init 4

2. Check out:

with command: opkg list-installed | grep mediasink

must give result:

gst-plugin-etmediasink - 0.10.0+git0+02cdde3c2ae8da95afdccd69f8676c0f98e9a4b5-r0

Contine with Step 4.

If you get the following output:

opkg list-installed | grep mediasink

gst-plugin-dvbmediasink - 0.10.0+git113+15a323f-r2

you must execute the following commands first:

opkg remove gst-plugin-dvbmediasink
opkg update && opkg install gst-plugin-etmediasink

Only execute the three commands in below, if you have previously installed any kind of DTS-Plugin:

/usr/lib/enigma 2/python/Plugins/SystemPlugins/DTS/
opkg remove *dreamdts*
init 4

After that check again with command opkg list-installed | grep mediasink
if it will display output mentioned in Step 3 only:

gst-plugin-etmediasink - 0.10.0+git0+02cdde3c2ae8da95afdccd69f8676c0f98e9a4b5-r0

If it is true, continue with step 5, otherwise re-execute the two commands again making sure that the old package gst-plugin-dvbmediasink will be removed and only the new one gst-plugin-etmediasink is installed.

5. Wipe gstreamer Caches with following command, attention make sure to execute the command “as it is” and listed in here on your currently active telnet/SSH Session:

rm -Rf /home/root/.gstreamer-0.10

6. Reboot of your Xtrend with command:


7. After E2-GUI is started, you can check the Mediaplayback with DTS.-Audio again.

It is important to have the AC3/DTS-Downmix „on“- active within the Audioselection Configuration Screen.

Your Xtrend Support Team


Sunday, March 25th 2012, 12:16pm


This solution does not work for me.
My movies with DTS sound does not work.



Sunday, March 25th 2012, 12:24pm

i've tried different trailers with DTS-5.1 and also lossless DTS-MA 5.1/7.1 - all without problems:
downmix works and also with deactivated downmix using output to my AVR.


Sunday, March 25th 2012, 12:30pm

No problems here at all.

Try with a clean re-flash with

Image from 25. 3. 2012

And do not restore anything.
--------------- Xtrend United ----------------------


Sunday, March 25th 2012, 12:57pm


and if is still fails:

do on cli:

init 4 && sleep 5

rm -Rf /home/root/.gstreamer-0.10

--------------- Xtrend United ----------------------


Sunday, March 25th 2012, 12:59pm

And btw:

the red "$" Symbol pops up

if a scrambled service

is decoded and displayed
--------------- Xtrend United ----------------------


Sunday, March 25th 2012, 1:12pm

I did a clean reinstallation of the Firmware yesterday, with this patch

I just made ​​the update online.

And despite the proposed solution, my movies with DTS sound not working

So I installed the firmware without any restoration of this day
I only mounted the network for access to my movies.
There is a problem with the DTS decoding because there are movies that no sound and another yes.
Sorry for my english, i use translate google



Sunday, March 25th 2012, 1:38pm


but do not complain that DTS

is not working

when only some files does not work

while others do.

It is now a Software-based Downmix

solution so issues might occur.

Supply Cuts (Samples) of the files

where DTS sound is not working

and sample files where it is well.
--------------- Xtrend United ----------------------


Sunday, March 25th 2012, 1:46pm

And issues seems to be

present on the DTS-Profile

MA / Core

having 48 KHz and 24-Bits

Maybe your "bad" files

use such a DTS-Sound-Profile?
--------------- Xtrend United ----------------------


Sunday, March 25th 2012, 2:27pm


Sunday, March 25th 2012, 8:10pm

The same problem here. Re-flashing not helped.


Sunday, March 25th 2012, 11:03pm

update again at this time and now is work OK.


Monday, March 26th 2012, 8:23am


thank you for confirmation, pieterg fixed it yesterday:

For reference see:…1da15a4b65eab47
Ihr Xtrend Support Team


Monday, March 26th 2012, 9:11am


Thank you XtrendsQS for the info of the author of the Fix, I will go and thank him


Monday, March 26th 2012, 9:14am

Hello demosat,

and keep up the good reporting (for every issue you get) in here.

Thank you.
Ihr Xtrend Support Team


Monday, March 26th 2012, 6:44pm


I still have a problem with the sound. I re-flashed last image and install last updates but on some movies the sound is damaged - seems like 8 bit sound.

Look media information on attached screenshot.

What I can to do? Is it a bug or I have done something wrong?
lexius has attached the following file:
  • problem.png (171.31 kB - 21 times downloaded - latest: Oct 6th 2014, 8:20pm)


Monday, March 26th 2012, 6:48pm

I suggest you

to supply a Sample

like demosat does

And screenshoot pop up

sound is AVC52 not DTS
--------------- Xtrend United ----------------------


Monday, March 26th 2012, 7:07pm

Ok. I have made a sample with avidemux (linux) and it playing without a problem, but the program asked me "Index is not up to date You should use Tool->Rebuild frame. Do it now ?" After this operation all playing fine with a good sound.
And now I have a question: on old openpli image without last changes the same file was playing without any problems, is it a bug? I think it is a broblem. There are to many videos with corrupted index.


Monday, March 26th 2012, 7:11pm

So supply the file

without any modifications.
--------------- Xtrend United ----------------------

Similar threads